Strange steering issue

Welcome to RCTalk

Come join other RC enthusiasts! You'll be able to discuss, share and private message with other members of our community.

Darnrightdifficult

RC Newbie
Messages
4
Reaction score
1
Hi everyone! So my brother got a Wltoys 124018 last August and it has worked just fine up until i couple months ago when the steering suddenly turned weird, so we took of the plastics/cover and the steering servo was really weak and making this ticking sound when you turned it and it would kinda chip forward and eventually jump till the max turning point were it continued making a ticking/buzzing sound. And as it gradually got worse and worse it wasn't listening to the controller att all.

So here's the weird part the throttle works just fine and so does the steering trim🤨..
When we adjust the steering trim the servo moves just fine to the left and right (it does make a little bit of sound but it seems usual) but when we turn the wheel on the controller absolutely nothing happens (sometimes it makes a weird sound but it doesn't move att all)

(Also worth noting that he has crashed the front of the car and has broken the front plastic swing arm but we have purchased a metal replacement kit for that)

Any help would be appreciated and if requested i can post both pictures and videos of it👍
 

STONER RC

BUILD it, SEND it, BASH it, FIX it, REPEAT
Lifetime Supporter!
Supporter
Excellence Award
Hospitality Award
Build Thread Contributor
Messages
4,031
Reaction score
3,320
Location
Brick, New Jersey
RC Driving Style
  1. Bashing
  2. Racing
  3. Crawling
  4. Scale Builder
  5. Boating
Hi everyone! So my brother got a Wltoys 124018 last August and it has worked just fine up until i couple months ago when the steering suddenly turned weird, so we took of the plastics/cover and the steering servo was really weak and making this ticking sound when you turned it and it would kinda chip forward and eventually jump till the max turning point were it continued making a ticking/buzzing sound. And as it gradually got worse and worse it wasn't listening to the controller att all.

So here's the weird part the throttle works just fine and so does the steering trim🤨..
When we adjust the steering trim the servo moves just fine to the left and right (it does make a little bit of sound but it seems usual) but when we turn the wheel on the controller absolutely nothing happens (sometimes it makes a weird sound but it doesn't move att all)

(Also worth noting that he has crashed the front of the car and has broken the front plastic swing arm but we have purchased a metal replacement kit for that)

Any help would be appreciated and if requested i can post both pictures and videos of it👍
Welcome to RCT bud. Sounds like you got some bindding going on in you linkage. After the crash. Did you check all the linkage of the steering. For any damage to the steering rods. For any bend/kinks in the linkage. Are the ball ends loose and got free play in them. Could be too tight and putting a stran on the servo.. be careful adding metal parts. Which adds weight and could have a effect on you esc. And burn that out as well.. I'm not a fan of the metal/aluminum A-arms or any of the suspension parts. The parts are made from plastic for a reason.. they are break points. Adding the metal. You will now push the break point onto something else. Which you might not want that to break... happy bashing bud 👍👍👍
 
Top