I need help with a second hand nitro rc

Welcome to RCTalk

Come join other RC enthusiasts! You'll be able to discuss, share and private message with other members of our community.

florin stanciu

RC Newbie
Messages
4
Reaction score
0
Hello guys, i have a problem with a nitro hpi trophy, as soon as I started the engine the car takes off, no matter the rpm the car has always traction even when the idle is about to die, I've tried putting i brand new clutch, clutch bell and bearings, but it's the same, what can cause that? Please please give me something
 

Greywolf74

I'M TO BLAME!
Lifetime Supporter!
Supporter
Hospitality Award
Build Thread Contributor
Messages
14,553
Reaction score
6,952
Location
Ohio
RC Driving Style
  1. Bashing
Hello guys, i have a problem with a nitro hpi trophy, as soon as I started the engine the car takes off, no matter the rpm the car has always traction even when the idle is about to die, I've tried putting i brand new clutch, clutch bell and bearings, but it's the same, what can cause that? Please please give me something
Using the wrong springs could cause that. If the springs are too soft for that particular engine then they could be allowing the clutch shoes to expand even at idle. Someone else here just recently had that problem and thats what his issue ended up being. If the springs are factory replacements for the kit then try getting some and see what happens.

Welcome to RCT btw :welcome_sign:
 

florin stanciu

RC Newbie
Messages
4
Reaction score
0
Folosirea unor arcuri greșite ar putea cauza asta. Dacă arcurile sunt prea moi pentru acel motor anume, atunci el ar putea permite saboților de ambreiaj să se extindă chiar și la ralanti. Altcineva de aici a avut recent această problemă și asta a ajuns să fie problema lui. Dacă arcuri sunt înlocuitoare din fabrică pentru kit, atunci încercați să obțineți unele și să vedeți ce se întâmplă.

Bine ați venit

Folosirea unor arcuri greșite ar putea cauza asta. Dacă arcurile sunt prea moi pentru acel motor anume, atunci ele ar putea permite saboților de ambreiaj să se extindă chiar și la ralanti. Altcineva de aici a avut recent această problemă și asta a ajuns să fie problema lui. Dacă arcurile sunt înlocuitoare din fabrică pentru kit, atunci încercați să obțineți unele și vedeți ce se întâmplă.

Bine ați venit la RCT btw:welcome_sign:
Hey, i really appreciate your time you spent answering me, but i bought this specific kit from hpi for my engine, the new spring it's much much stronger than the old burned one
 

Greywolf74

I'M TO BLAME!
Lifetime Supporter!
Supporter
Hospitality Award
Build Thread Contributor
Messages
14,553
Reaction score
6,952
Location
Ohio
RC Driving Style
  1. Bashing
Hey, i really appreciate your time you spent answering me, but i bought this specific kit from hpi for my engine, the new spring it's much much stronger than the old burned one
Check and make sure your throttle trim in set to neutral?
 

florin stanciu

RC Newbie
Messages
4
Reaction score
0
Verificați și asigurați-vă că reglajul clapetei de accelerație este setat pe neutru?
Yes I've checked it, and i tried riching it as much as possible to keep a low rpm bu the wheels are spinning until it dies
Can you post a photo of the clutch installed on the flywheel?

Is this your first nitro? Your only nitro?
I will post tomorrow morning, no this is not my first nitro and not my only one, none of them did that until now and it's driving me crazy... :(
 

Hpi nitro junkie

RCNT Member
Messages
32
Reaction score
18
Is the clutch bell shimmed out properly? It could be contacting the edge of the clutch facing the teeth of the bell housing. I'd bet your not shimmed right.
 

tudordewolf

RCNT Talkaholic
Messages
245
Reaction score
126
Yes I've checked it, and i tried riching it as much as possible to keep a low rpm bu the wheels are spinning until it dies

I will post tomorrow morning, no this is not my first nitro and not my only one, none of them did that until now and it's driving me crazy... :(
Try adjusting the idle with the idle gap instead of the low-speed needle, it's possible the idle gap is too large and this is adding to the problem.

The bearings for the clutch bell might also be shot, did you change those too?

When the engine is off, does the clutch bell spin freely? Ideally, the whole drivetrain should coast / spin for a few seconds if you push the car along the ground and pick it up. That'll start to show you where the motion is coming from.

Noroc!
 

florin stanciu

RC Newbie
Messages
4
Reaction score
0
Try adjusting the idle with the idle gap instead of the low-speed needle, it's possible the idle gap is too large and this is adding to the problem.

The bearings for the clutch bell might also be shot, did you change those too?

When the engine is off, does the clutch bell spin freely? Ideally, the whole drivetrain should coast / spin for a few seconds if you push the car along the ground and pick it up. That'll start to show you where the motion is coming from.

Noroc!
I've mentioned up above that i lower the rpm's until it dies (from the idle gap and low speed needle) and yes it does spins freely when the engine is off and the kit comes with new clutch shoes and spring, clutch bell, bearings, and washers...thank you all guys for trying to help me !!!!!! You really are amazing i never thought somebody will reply me
 

alfredwong2003

RCNT Talkaholic
Messages
347
Reaction score
103
It could also be the screw that hold the clutch bell in is too tight. You may want to use some thread lock and not tightened too much and wait for the thread lock to cure.
 

gandalfnz

RCNT Addict
Messages
595
Reaction score
309
Location
The Shire - NZ
When you spin the clutch bell with your finger, does it spin freely for a few seconds or there is resistance to it?
If it spins freely, either your clutch shoes spring is too weak, or your definition of low RPM is still too high for idle speed.
Hope that makes sense.
 

Greywolf74

I'M TO BLAME!
Lifetime Supporter!
Supporter
Hospitality Award
Build Thread Contributor
Messages
14,553
Reaction score
6,952
Location
Ohio
RC Driving Style
  1. Bashing
When you spin the clutch bell with your finger, does it spin freely for a few seconds or there is resistance to it?
If it spins freely, either your clutch shoes spring is too weak, or your definition of low RPM is still too high for idle speed.
Hope that makes sense.
He stated above that he bought a clutch spring/shoe kit specifically for his kit so I'm assuming its not weak clutch springs?
 

Hpi nitro junkie

RCNT Member
Messages
32
Reaction score
18
Either way he has to take it back apart, something went wrong with the clutch sonmewhere.....
 

cbaker65

RCNT VIP
Messages
6,029
Reaction score
3,261
Location
Kern county ,Calif.
Just like Alfred said ,it is possible to pinch the clutch bell bearings with the screw if the bell isnt
shimmed right an your not using the right washer on the screw ,I've done it many times!..:thumbs-up:
 

Kevinb

RCNT Rookie
Messages
22
Reaction score
6
I've seen many people not installing the springs correctly. I'm not saying you installed them wrong at all.
You do have the springs tensioned on the flywheel nut?
Another thing
Sometimes people who don't have the springs tool, hyperflex the springs when using a screwdriver to flip the springs into the flywheel nut. I.e over spreading the spring.
This could weaken the springs tension and too weak of springs will allow the shoes to spread open at low rpm.
I use a screwdriver many moons ago when I was a kid, I had weakened many springs that way.
I still use a screwdriver now after years, I do it a certain way that my springs are so tight the shoes won't open fully so I have to hyperflex each shoe too weaken the springs.
The actual tool for springs actually hyperflex the springs to the correct flex point to allow the shoes to fully spread and engage properly.
Lol but I like doing it my way, this way I can adjust the tension my self.
 
Last edited:

fernando mateus

RCNT Rookie
Messages
15
Reaction score
1
Location
South River nj
RC Driving Style
  1. Racing
Hello guys, i have a problem with a nitro hpi trophy, as soon as I started the engine the car takes off, no matter the rpm the car has always traction even when the idle is about to die, I've tried putting i brand new clutch, clutch bell and bearings, but it's the same, what can cause that? Please please give me something
Either your spring is broken or is too big for the clutch I was just fight a new clutch it's not that much money
Either your spring is broken or is too big for the clutch I was just fight a new clutch it's not that much money
Sorry the message came wrong buy a new clutch
 
Top