Redcat SH.18 will not start.. Help needed

Welcome to RCTalk

Come join other RC enthusiasts! You'll be able to discuss, share and private message with other members of our community.

Register Log in

2GMitsubishi

RCNT Basher
Messages
70
Location
Moscow, ID
RC Driving Style
Bashing, Racing
My Volcano S30 will not start.. I have new fuel, new fuel filter, I cleaned the lines out just to be sure..
My carb settings are LSN 3 turns out and HSN 3 1/2 turns out.
New hot glow plug that tested good and I've got a full charge on my igniter.
Wtf could be the issue?
I've adjusted the LSN a quarter turn at a time from fully closed to four turns open and no where in between did I get a start.
It is a rotary carb
My idle is set at 1mm open.
The engine has a Mild port and polish..
 

jeffgnz

RCNT Member
Messages
30
Location
Palmerston North, New Zealand
RC Driving Style
Bashing
With my SH .18 I always have to turn the throttle trim up to open the gap up to get it started, then trim it back down once it fires up. I presume this is normal though?? I've never used anything else, this is my first nitro car. I set the LSN to about 3.5-4 turns out from memory, at 3 it seemed a bit lean on the pinch test, but that shouldn't stop it from starting though.
 

cbaker65

Hardcore RCNT User
Messages
3,405
Location
Kern county ,Calif.
My Volcano S30 will not start.. I have new fuel, new fuel filter, I cleaned the lines out just to be sure..
My carb settings are LSN 3 turns out and HSN 3 1/2 turns out.
New hot glow plug that tested good and I've got a full charge on my igniter.
Wtf could be the issue?
I've adjusted the LSN a quarter turn at a time from fully closed to four turns open and no where in between did I get a start.
It is a rotary carb
My idle is set at 1mm open.
The engine has a Mild port and polish..
If theres fuel flow to the carb. ,it should fire ,is the head bolts tight an the head have a good seal?
An just like Jeff said ,sometimes engines needs a little bit more on the gap!..,My Hyper 21 engine
has to be opened & closed by the transmitter before it will start!..:cool:
 

2GMitsubishi

RCNT Basher
Messages
70
Location
Moscow, ID
RC Driving Style
Bashing, Racing
Yeah they are tight, I torqued them like a head on an old ford lol.. I am getting fuel but it only wants to start if its flooded for some reason and then it dies once it burns that fuel up. I tried opening the throttle up with the remote while starting but to no avail.
 

jeffgnz

RCNT Member
Messages
30
Location
Palmerston North, New Zealand
RC Driving Style
Bashing
Have you tried it without the filter in case that's causing a problem? Or turn it around in case its directional? Somethings obviously stopping fuel from flowing through, but if it primes OK that seems strange to me.
 

2GMitsubishi

RCNT Basher
Messages
70
Location
Moscow, ID
RC Driving Style
Bashing, Racing
Yes I am trying it without the filter on. It is priming really well but not igniting. I just got done talking to redcat and they said the stock setting for the lsn is 2 1/2 out not 3 1/2.
I'm running a hot glow plug and 20% nitro.
I just got done taking the tank out and flushing it spotless with nitro and did the same with both fuel lines and the fuel filter..
Tried again after I got it back together and no start..
Honestly if I wasn't almost 500bucks into a $200 truck it would be gone by now.. But I'm in too deep now no turning back.

Got to say though I just found out the best way to clean your nitro is disassemble, clean and reassemble lol
At least its clean now
 

watertrucker

RCNT Talkaholic
Messages
249
Mine did the same thing one day. I ran it in the morning and whe I went to start it a couple hours later, nothing. Glow plug was lighting up and I put the needles back to factory settings. Wouldn't fire. Finally in desperation I pulled glow plug and put in a Traxxas 3232X plug. It fired right up! You might try a different plug. Sometimes they look ok on the ignitor but just won't fire the fuel.
 
Top