Futaba 4PLS Radio Binding Issues

Welcome to RCTalk

Come join other RC enthusiasts! You'll be able to discuss, share and private message with other members of our community.

Register Log in

amithus

RC Newbie
Supporter
Messages
9
Location
Minneapolis MN
RC Driving Style
Bashing, Racing
Ok, so I finally got a nice radio to replace all the crappy "RTR" radios I've been using. I bought a Futaba 4PLS and wow this thing is nuts. I hate to admit it but I'm a corporate IT contractor responsible for colocation of cloud services and exchange servers but I can't figure this thing out.....

Ok, so I have put the radio in "DISP" mode, I have selected "Model 2" I rebooted the unit, went into "RX Mode", hit the "Link: EXEC" and it gives me the 20 second count down. I have my receiver about 10 inches away and powered up through the same battery that I use for my other model which I know is charged, I've also used other batteries but still no luck. I hold down the "SW" button on the receiver but I never get a link. No lights, no blinking, nothing. I know the 4pls is a T-FHSS radio and the 2nd transmitter I purchased is a Futaba R203GF S-FHSS (no telemetry) so both the radio and receiver are FHSS. I've tried changing the radio's transmit to S-FH and FHSS modes, rebooted it but there is no "Link:EXEC" under that like there is in the T-FH. Actually I scrolled through all the other options and the only part that has the link exec function is the T-FH modes for both High and Normal.

I was surprised to see that there really isn't anything on the internet about this... I have googled it, read the manual and my god, this thing is worse than an NT4.0 exchange server...

Any help would be much appreciated.

I must say, I cleared the first model and attempted to re-bind that and it worked without an issue so I'm guessing that either I got a bunk receiver or I'm doing something wrong. I just find it funny that there isn't a link feature under any of the other radio modes.
 

amithus

RC Newbie
Supporter
Messages
9
Location
Minneapolis MN
RC Driving Style
Bashing, Racing
Well I found out what I need to do. There is no binding for a non-telemetry receiver so all you need to do is set the transmitter to s-fh and then turn it on all the way and just bind as normal with the receiver button only. Worked like a charm. :)
 
Thread starter Similar threads Forum Replies Date
PWells Electronics 10
I Electronics 2
tadpole1991 Electronics 2
WoodiE Electronics 1

Similar threads


Top