I just rebuilt my Speedgems, some questions

Welcome to RCTalk

Come join other RC enthusiasts! You'll be able to discuss, share and private message with other members of our community.

Scrogg

Hardcore RCNT User
Messages
3,335
Reaction score
0
Location
Aiken
RC Driving Style
  1. Bashing
  2. Racing
I have an older 16TX3 Speedgems, it had an intermitent operating problem. Well i had a set of brushes for it, tore the motor down cleaned and lubed the bearings. Scuffed the burnt arc markings off the com. with a soft wire wheel. scuffed all the contacts.put it all back together and the same intermittent problem is still there. if I push in one of the brushes it works, so i assume the springs are too weak/worn. I have swapped the springs around with the same results. Sound right so far?
Next problem, there are no timing marks or reference marks anywhere. i should have marked it i know.
So what i have done so far is rotate the endbell for maxx rpm, then backed up a bit. is this correct? Any help would be appreciated. i'd like to get my Tamiya buggy back in action. I have not been able to drive an R/C in quite a while now. I'm also anxious to see if it runs better than the previous owners rebuild did.
i figure this motor in a 4wd buggy should at least be able to keep up with the 19T trucks, so far it has not.
My ESC is a 15T LRP Ai.
 

ohmygahitscoby

Hardcore RCNT User
Messages
3,111
Reaction score
0
Location
San Jose
RC Driving Style
  1. Bashing
I think the the first problem was that the brush wasn't long enough. Not sure about the second one though.
 

Scrogg

Hardcore RCNT User
Messages
3,335
Reaction score
0
Location
Aiken
RC Driving Style
  1. Bashing
  2. Racing
The brushes in it are new, the others were close to worn out.
 

Scrogg

Hardcore RCNT User
Messages
3,335
Reaction score
0
Location
Aiken
RC Driving Style
  1. Bashing
  2. Racing
Well I cleaned and put the buggy all back together, it flies in the living room! Did not cut out on me once. Just need some nice weather now.
I swear to god everyday i have had off for the past two months it has rained on me!
 

Similar threads

Top