Hello All, noob here

Welcome to RCTalk

Come join other RC enthusiasts! You'll be able to discuss, share and private message with other members of our community.

Register Log in

Ratty

RC Newbie
Messages
5
I am new to nitro and RC in general and i made the mistake of buying the BIY Condor for my boy. it was something for us to do together but i did ot research well and have now seen all the negatives about. with that being said i hope i could get some helpful info on here.

I guess the first point is that it doesn't prime very well. On occasions i have had to blow the fuel in but having built the car now on 2 seperate occasions after starting to start break in, after a short time it seems to get mega hot (no temp gun) to the point the engine looks like it is smoking then the throttle seems to go full blast all on its own. The car was idling a little high altough the carb is set to around 1mm and I haven't mucked with the needles at all. It has happened twice now and both times because we were holding car when it went beserk it stripped the spur gear and left the engine gear spinning for nearly a minute after we cut it off.

I have tried to research this myself, I have read many posts about linkage and such, but again carb is not being moved from the 1mm so i can see no reason why it just goes beserk on it's own. I have seen a couple of posts that make me think it might be an Air leak but tbh if that may be the case they can replace it being it's new rather then me go through the test.

If anyone can provide any useful comments or questions i can answer, it would be appreciated. I feel bad for my boy, we have had it built a month and only managed 1 tank and not even driven it in anger yet.

Please leave the ACME told you so comments out of it lol
 

cbaker65

Hardcore RCNT User
Messages
3,242
Location
Kern county ,Calif.
I am new to nitro and RC in general and i made the mistake of buying the BIY Condor for my boy. it was something for us to do together but i did ot research well and have now seen all the negatives about. with that being said i hope i could get some helpful info on here.

I guess the first point is that it doesn't prime very well. On occasions i have had to blow the fuel in but having built the car now on 2 seperate occasions after starting to start break in, after a short time it seems to get mega hot (no temp gun) to the point the engine looks like it is smoking then the throttle seems to go full blast all on its own. The car was idling a little high altough the carb is set to around 1mm and I haven't mucked with the needles at all. It has happened twice now and both times because we were holding car when it went beserk it stripped the spur gear and left the engine gear spinning for nearly a minute after we cut it off.

I have tried to research this myself, I have read many posts about linkage and such, but again carb is not being moved from the 1mm so i can see no reason why it just goes beserk on it's own. I have seen a couple of posts that make me think it might be an Air leak but tbh if that may be the case they can replace it being it's new rather then me go through the test.

If anyone can provide any useful comments or questions i can answer, it would be appreciated. I feel bad for my boy, we have had it built a month and only managed 1 tank and not even driven it in anger yet.

Please leave the ACME told you so comments out of it lol
A high rev on its own means its leaning out ,so that means lack of fuel causing the high rev!

You have to figure out why!
  1. Its either a lack of fuel pressure from the tube that goes from muffler to the fuel tank ,or the fuel tank is not sealing at the lid an not holding pressure.

  2. A dirty tank filter.

  3. The HSN needle is not opened up enough or could be clogged.
 

cbaker65

Hardcore RCNT User
Messages
3,242
Location
Kern county ,Calif.
OK, I will have a look at the fuel tank and pipes. Thank you for the respone
No problem!...:cool:

Just because its an off brand ,doesn't mean that it isn't going to run right ,this is the horrors of mass production RTR's!

Never ever trust a manufacture set up on any brand ,I've seen stupid stuff come out of the box from them ,like
missing screws in a 2 spd clutch hub an the carb settings way off for break-ins!....:hehe:
 

Ratty

RC Newbie
Messages
5
hey, so was having another look. Still doesn't prime easily. if i take pipe of exhaust then blow sometimes the tank lid opens. I presume thats not right?
 

cbaker65

Hardcore RCNT User
Messages
3,242
Location
Kern county ,Calif.
hey, so was having another look. Still doesn't prime easily. if i take pipe of exhaust then blow sometimes the tank lid opens. I presume thats not right?
No ,that's right!

That tells me that there is no escape route for the pressure to go ,now ,it maybe clogged filter or the
need valve is not open enough ,Try opening the HSN needle about a half a turn an see if the fuel
flows easier!...:cool:
 

Ratty

RC Newbie
Messages
5
Hey all, had to wait for new spur gear before I could try it. after taking everything apart and just putting back together engine now primes straight off so I thought that might solve it. made sure carb was at 1mm and started it. again tho almost instantly car wanted to go and the revs were escalating even tho no throttle applied. really not sure what else to do.
 

jeffgnz

RCNT Member
Messages
30
Location
Palmerston North, New Zealand
RC Driving Style
Bashing
Hey all, had to wait for new spur gear before I could try it. after taking everything apart and just putting back together engine now primes straight off so I thought that might solve it. made sure carb was at 1mm and started it. again tho almost instantly car wanted to go and the revs were escalating even tho no throttle applied. really not sure what else to do.
Once the engine starts, try turning the throttle trim on your controller down to close the carb gap even further.
 

Ratty

RC Newbie
Messages
5
ok so i think i'm almost there now. still think it is idling a little high but this is only 2nd tank and still rich. if i brake the carb closes even further so I guess thats right. I think the throttle linkage was is a problem for me. struggle to get it exact plus if too much pressure is applied the throttle lever just turns which puts the set up all out.

did a vid, ignore the brake pin.
 

cbaker65

Hardcore RCNT User
Messages
3,242
Location
Kern county ,Calif.
I see your brake rod is loose ,an you should have a collar with a little spring on the back side
of the throttle rod ,so it is probably a linkage adjustment problem in which does confuse
people sometimes on how to set them up!..:cool:
 

Similar threads


Top