• GIVEAWAY: ASSOCIATED DR10 DRAG CAR and GIFT CARD!!! ENTER NOW!!

Align TRex 470L

Welcome to RCTalk

Come join other RC enthusiasts! You'll be able to discuss, share and private message with other members of our community.

Rayce

RC Newbie
Messages
11
Reaction score
0
Location
Alaska
RC Driving Style
  1. Racing
  2. Crawling
  3. Flying
I just got a used Align TRex 470L heli with spectrum receiver, microbeast plus gyro and a got a new Spectrum DX6e radio. Set up the radio with all flight settings and got it to bind with heli, but no controls work. Looked everywhere online and in heli, microbeast plus, and remote manuals and can’t figure out the problem. Anyone have an idea?
 

Attachments

  • 99841DC3-CA15-447A-A0F6-D9D843B397C8.jpeg
    99841DC3-CA15-447A-A0F6-D9D843B397C8.jpeg
    246.5 KB · Views: 7
  • 068A5EC1-D308-40BE-8404-83E868E9F157.jpeg
    068A5EC1-D308-40BE-8404-83E868E9F157.jpeg
    180 KB · Views: 6
  • 267BA606-B582-4C46-807E-83D4A72F8C5E.jpeg
    267BA606-B582-4C46-807E-83D4A72F8C5E.jpeg
    178.6 KB · Views: 8
  • DE45A601-6DD4-47E1-ADB0-375D022A7C8E.jpeg
    DE45A601-6DD4-47E1-ADB0-375D022A7C8E.jpeg
    202.6 KB · Views: 5

Tunedpipe

AKA KvConivore
Supporter
Military Veteran
Messages
2,751
Reaction score
2,621
Location
Idaho
RC Driving Style
  1. Bashing
After you set up everything, did you re-calibrate it?
To be honest, I don't know anything about your chopper or the receiver but I do have a Spektrum DX6e.
 

Greywolf74

I'M TO BLAME!
Supporter
Build Thread Contributor
Messages
10,079
Reaction score
3,123
Location
Ohio
RC Driving Style
  1. Bashing
Sorry Rayce, I'm a real novice at helis and I'm not familiar with the microbeast gyro system. Hopefully one of the more experienced people will chime in.

One thing that worries me though is it looks like the RX antenna has been cut. I've had bad experiences with ground kit with damaged antennas. Id hate to see something bad happen to a 450 sized heli :)
 

Rayce

RC Newbie
Messages
11
Reaction score
0
Location
Alaska
RC Driving Style
  1. Racing
  2. Crawling
  3. Flying
After you set up everything, did you re-calibrate it?
I don’t think so, I got the heli used from a local hobby shop, and the remote new. The staff at the shop said that since the receiver and remote are both spectrum it should just bind and from there just flight settings. I set those up and it just binds, and the blades all level. No signals seem to be sending to control heli. I’m new to helicopters with this kind of tech. I’ve only flown drones with the remote included with the buy.
Sorry Rayce, I'm a real novice at helis and I'm not familiar with the microbeast gyro system. Hopefully one of the more experienced people will chime in.

One thing that worries me though is it looks like the RX antenna has been cut. I've had bad experiences with ground kit with damaged antennas. Id hate to see something bad happen to a 450 sized heli :)
Yea it is damaged a bit, came that way 😩
 

Tunedpipe

AKA KvConivore
Supporter
Military Veteran
Messages
2,751
Reaction score
2,621
Location
Idaho
RC Driving Style
  1. Bashing
I would take it back to them and have them check it out. I know some radios require you to re-calibrate otherwise the transmitter and receiver won't communicate with each other until you do. Another words, the receiver needs to know you changed something so to speak.
 

Rayce

RC Newbie
Messages
11
Reaction score
0
Location
Alaska
RC Driving Style
  1. Racing
  2. Crawling
  3. Flying
I would take it back to them and have them check it out. I know some radios require you to re-calibrate otherwise the transmitter and receiver won't communicate with each other until you do. Another words, the receiver needs to know you changed something so to speak.
Okay that makes sense, I came back today and they said their chopper guru is coming in tomorrow 😂 and one of the receiver antenna are short like it was cut. And I know those are a big deal. You think that would cause it to not get commands?
 

Tunedpipe

AKA KvConivore
Supporter
Military Veteran
Messages
2,751
Reaction score
2,621
Location
Idaho
RC Driving Style
  1. Bashing
Yes. I would let the chopper guy get it set up for you.
 

Tunedpipe

AKA KvConivore
Supporter
Military Veteran
Messages
2,751
Reaction score
2,621
Location
Idaho
RC Driving Style
  1. Bashing
Good luck with it and welcome in. I wish I could offer more advise and the right advise but again all I know is some need re-calibrated and to be honest, a cut antenna is not good.
 

Rayce

RC Newbie
Messages
11
Reaction score
0
Location
Alaska
RC Driving Style
  1. Racing
  2. Crawling
  3. Flying
I’m definitely purchasing a new receiver, but talking to the guys at the hobby shop will help with the set up for future builds and buys that I have!
 

Rayce

RC Newbie
Messages
11
Reaction score
0
Location
Alaska
RC Driving Style
  1. Racing
  2. Crawling
  3. Flying
Did you try it before the microbeast was added? Curious if it worked with just the receiver.
I did unplug the microbeast, and it was able to bind with the remote still. I don’t know if that answers your question or not. I bought the chopper with the receiver and Microbeast Plus hooked up.
Did you try it before the microbeast was added? Curious if it worked with just the receiver.
Do you mean trying to hook the servos directly to the spectrum receiver and bypassing the microbeast?
 
Last edited:

Doom!

Team Dust Devil
Supporter
Build Thread Contributor
Messages
1,464
Reaction score
1,872
Location
Central California
RC Driving Style
  1. Bashing
  2. Crawling
  3. Flying
Yes, that would let you know if there is a problem with the receiver. If the receiver and all of the controls work without the microbeast, it may be a communication problem between the two.
 

Rayce

RC Newbie
Messages
11
Reaction score
0
Location
Alaska
RC Driving Style
  1. Racing
  2. Crawling
  3. Flying
Yes, that would let you know if there is a problem with the receiver. If the receiver works without the microbeast, it may be a communication problem between the two.
Okay I’ll check that out now, thanks!
Yes, that would let you know if there is a problem with the receiver. If the receiver and all of the controls work without the microbeast, it may be a communication problem between the two.
Yes it works if I bypass the microbeast! But the blades aren’t level. Is that something I can change up in the transmitter’s settings?
Did you try it before the microbeast was added? Curious if it worked with just the
Yes, that would let you know if there is a problem with the receiver. If the receiver and all of the controls work without the microbeast, it may be a communication problem between the two.
seemed to get all the controls to work but no motor function.. is there a reason why the throttle won’t work when bypassing the microbeast?
 
Last edited:

Doom!

Team Dust Devil
Supporter
Build Thread Contributor
Messages
1,464
Reaction score
1,872
Location
Central California
RC Driving Style
  1. Bashing
  2. Crawling
  3. Flying
Maybe try setting all your settings back to default and try re-binding. If that doesn't work, I would leave it up to the hobbyshop guys to trouble shoot. It's a bit tricky to do when I don't have it in front of me.
 

Rayce

RC Newbie
Messages
11
Reaction score
0
Location
Alaska
RC Driving Style
  1. Racing
  2. Crawling
  3. Flying
Maybe try setting all your settings back to default and try re-binding. If that doesn't work, I would leave it up to the hobbyshop guys to trouble shoot. It's a bit tricky to do when I don't have it in front of me.
After doing all that, resetting all the settings / starting a new model, then setting up the throttle thresholds on the Castle Phoenix EDGE Lite 50 with the remote fixed her up. All functions work fine now. Curious why the previous owner added the microbeast plus onto it.
 

Rayce

RC Newbie
Messages
11
Reaction score
0
Location
Alaska
RC Driving Style
  1. Racing
  2. Crawling
  3. Flying
They were probably wrong about the remote.
The remote and receiver worked fine, in the end it was the Microbeast Plus. It was stuck in a weird bind mode but wouldn’t bind and we couldn’t go through the settings on it. Eventually we reset it and got it going. Seems to work now but the controls seem to be backwards. Throttle side works (throttle up, throttle down/rudder left and right) but my aileron and Pitch seem to be backwards.
 
Top